CertificationISISNetworking

IS-IS Network Types

IS-IS Network Types:

IS-IS, in contrast to OSPF, supports only two network types (or subnetwork types, in IS-IS terminology):

  • Broadcast (LAN) networks
  • General topology networks

Broadcast networks are the same in IS-IS as they are in OSPF: networks to which more than two devices can attach, and over which a single PDU can be received by all attached devices. As with OSPF, the primary characteristic of an IS-IS broadcast network type is that a DIS is elected to represent the network as a pseudonode. Also as with OSPF, there is an assumption that a single PDU sent to one of the two IS-IS multicast MAC addresses AllL1ISs (0180.c200.0014) or AllL2ISs (0180.c200.0015) can be received by all attached IS-IS routers.

General topology networks are point-to-point links. The IS-IS spec breaks this network type down into several subtypes, but for our purposes it is sufficient to say that this second network type is point to point. IS-IS PDUs are unicast on general topology networks.

ISO 10589 includes a specification for virtual links, but unlike OSPF IS-IS does not classify virtual links as a separate network type. The distinction is irrelevant for us anyway, because commercial implementations of IS-IS do not support the virtual links option. The most noticeable difference from OSPF is that IS-IS has no equivalent of the OSPF NBMA and point-to-multipoint network types for NBMA support. But, as discussed in the preceding section, modern implementations of Frame Relay and ATM networks with very few exceptions treat each VC either as a distinct subnet or as an IP unnumbered link, rather than treating the entire NBMA “cloud” as a single subnet. As a result, both IS-IS and OSPF are normally configured to treat NBMA VCs as point-to-point network types.

Figure 4.32 shows an example of an IS-IS configuration on a NBMA network. In this example, the network is ATM and the configuration is JUNOS rather than IOS. But the concept of configuring each VC as an individual subnet is the same as the example in Figure 4.31.

Figure 4.32. An IS-IS configuration for an ATM network, in which each VC is treated as a point-to-point link with its own subnet.
interfaces {
        at-3/1/0 {
            atm-options {
                vpi 0 maximum-vcs 512;
            }
            unit 101 {
                encapsulation atm-snap;
                point-to-point;
                vci 0.101;
                family inet {
                    address 10.1.1.1/30;
                }
                family iso;
            }
            unit 102 {
                encapsulation atm-snap;
                point-to-point;
                vci 0.102;
                family inet {
                    address 10.1.1.5/30;
                }
                family iso;
            }
            unit 103 {
                encapsulation atm-snap;
                point-to-point;
                vci 0.103;
                family inet {
                    address 10.1.1.9/30;
                }
                family iso;
            }
        }
protocols {
    isis {
        interface at-3/1/0.101;
        interface at-3/1/0.102;
        interface at-3/1/0.103;
     }

Related Articles

Leave a Reply

Your email address will not be published. Required fields are marked *

bpN fQ5Q O0o

Please type the text above:

Check Also

Close
Close
Close